FACER Community

After recent bug fixes for Galaxy watch 4 update facer still hangs in "always on" mode

This works. :blush: :blush: :blush:

Samsung/Google added this to control apps in the background?
AND TOLD NOBODY about it for 3rd Party Face apps with the Feb 9 update!

SPREAD THE WORD!

@mrantisocialguy Nice find - this was the problem.
@Facer_Official

1 Like

They should have made it on by default. On my GW4 Classic it worked fine, but my GW4 “Active” it’s greyed out and I can’t change it even if I wanted to. It’s just a good thing that I don’t use AOD active mode anyway, but it would be nice for testing Facer watch faces on. Oh Well…

1 Like

My GW4 Classic drain battery when enable background activity for Facer. Kind of wachface does not matter.

Can confirm this worked for my galaxy watch 4 classic as well. Also, @mrantisocialguy , I absolutely LOVE your watch faces!! about 85% of my watchbox faces are yours. Keep it up, man!! cheers.

1 Like

Thank you!

@Facer_Official. Is there any news on the fixes for all the things the latest app update has messed up with WearOS 2, especially that it no longer reports phone battery at all to the watch?

I have seen no response to this on the 4 day old post (and reported directly by email): Android companion app and time speed up

You have broken the hundreds of thousands of WearOS 2 devices in the last update as the app no longer sends any phone battery data except when a new face is synced. I have tried multiple faces, I have tried switching faces, I have tried watch restarts; Only on new sync does the current battery level get send and then it is static on the watch until next sync.

This is a fundamental flaw acrous thousands of faces.

I maybe should have reported id seperately but it’s not a feature request, there is no bug report category on the forum and I can’ tlog in to help.facer.com as it does not accept my facer credentials.

The facer help system is separate from the normal facer login / registration and so requires a new registration. You can use the same username and password to make easier.

1 Like

Yeah. I realise this but that’s a stupid approach. facer.io and community.facer.io use the same credentials. It is jarring and awkward that help.facer.io cannot.

2 Likes

I have background activity allowed and the always on display still doesn’t update every minute. I get the hourly chime, look at the watch and its still on the previuos hour.

“The facer help system is separate from the normal facer login / registration and so requires a new registration. You can use the same username and password to make easier.”

Y’all need combine the two like everybody else in the world does, it’s not exactly a privacy issue why somebody coded it this way, it’s just making more stuff for your clients to do in order to try to communicate bugs on our end.

Every website I go to all of this stuff is combined in their menu system. Once you’ve logged in you have access to all of their different areas including their forums if they have them. If your it guy doesn’t know how to do this get someone else

1 Like

Now about an issue that I have found and the always on display sometimes it just shuts off on its own and I have to tap the watch to have my always on display pop up again and then when it does it seems like the time is also stopped moving in the background and the time resets itself whether it’s 20 minutes or 40 minutes behind it has to catch up for waking up the watch. It doesn’t shut off the always on display from the settings it just acts like it does

And this is after the facer app was updated a few days ago. But actually it did that before also

Sorry but I don’t work for Facer so I have no ability to change the system. My comment just related to my experience of what works if someone wants to interact with the help system as it is now.

Facer does not change the way the watch is programmed to operate. It is just an app like Google Fit, Samsung Health etc. WearOS for some reason does turn off AOD after a predetermined time. I have a Fossil Carlyle test watch on my desk right in front of me. I have AOD turned on and the watch will stay lit in ambient mode for a while then it goes dark. I believe Samsung Tizen also does that, but I’m not 100% sure on it since I don’t use AOD except on my test watch. The AOD ambient mode is totally controlled by the watch manufacturer and cannot be changed except for us being able to turn it on or off.

1 Like

My fossile Gen 6 seems to stay lit but get dimmer over time if I am active. It seems to go black when it thinks I might be asleep so loafing on the sofa in front of the telly can be a false positive.

1 Like

Hi, I have the same issue (GW4). It’s not present on Samsung Watch on Tizen (my son watch).

1 Like

GW may treat AOD idffrenetnty I don’t lnow It is why I identified my watch when descibing behaviour.

Perhaps a description og your current settings for AOD on the watch, any battery overrride settings and a descriptioion of what you ecpect to dee over what you are seeing and at least one person here should be able to shed light.

I have a similar issue with the “allow background activity” option. For me, it’s greyed out on all the apps under that menu.

1 Like

I’m having this same issue as well, the option to allow background activity is grayed out. And even after the update it’ll still hang.

I am having this issue on my watch. Facer is set to ‘allow background activity’ but it still can lag by several minutes before updating the time on the watchface

1 Like