FACER Community

After recent bug fixes for Galaxy watch 4 update facer still hangs in "always on" mode

After I updated my watch with Galaxy software. I noticed that the facer watch faces were acting funny and freezing

You had a bug fix within hours which I uploaded to my phone and it took care of most of them. But there was still one that has not been addressed. Possibly two

When my watch goes into always on mode the minute hand no longer works unless I tapped the watch to take it out of always on mode and then the minute hand catches up to where it should be.

And sometimes if facer reloads itself it just picks a watch face that I’ve never seen before in loves it and I don’t do the spin the wheel deal for new faces.

So I think you guys still have a little bug to fix. I have a Samsung Galaxy watch 4 classic 42 mm.

Welcome to the Facer Community pages. I’ve got the Galaxy 4 and the Galaxy 4 Classic. With Facer the watch in AOD ambient dim mode will never have a moving seconds hand. Facer only updates the face once a minute so the second hand will only move once to return to the 12 o’clock position and will stay there. This is done for battery saving reasons. The Facer default is to not show the second hand in ambient mode, but some creators make it show on their own. I’ve never experienced Facer reloading and showing a face I’ve never seen, but I have seen it show a face that I have used before, but not the current one. The only other thing I have seen is sometimes when I check the time, the face will show itself as in ambient dim mode, but then switch to the active face. By the way I do not use AOD mode, so I don’t understand why that happens. Since it’s a new watch running a new operating system for Samsung plus being a new version of the WearOS system there are bound to be issues. Hopefully they will get them fixed soon.

I don’t know if this is an automated response or not that I’m reading. But I made it very clear in my post that the minute hand does not move when the minutes advance in always on mode. I know that the second hand disappears or stops and then finally wind up with the 12 is ishen I never mentioned that that’s not the issue

Let me put it in another way,

if I have a digital watch face the minute well freeze let’s say it’s 10:25. And 4 minutes goes by, the watch still says 10:25 in always on mode. I would have to take it out of always on mode by touching the watch face for it to update automatically.

Sorry, I misunderstood you. 99% of the time when people complain about AOD it’s because of the second hand. You are correct, the minute hand should be moving at least one step every minute in AOD mode. Since I don’t ever use AOD except on my Fossil Carlyle test watch I have never seen that problem. Your best bet at this time would be to contact @Facer_Official at: https://help.facer.io/hc/en-us/requests/new or email them at: facer-support@little-labs.com I’m sure they would be interested in knowing about your issue.

I confirm the problem. Reported in support of Facer.

I can also confirm the problem. This is not limited to Facer. Also applies to Watchmaker and to commercial watchfaces purchased from the Play store (Roto Rally, Minimalin etc). Samsung/Google apparently have changed something in the onTimeTick() method and forgot to tell the 3rd party dev community…

I added this information to my bug report.

Hey guys,

Thanks for the report. We confirm the issue on our side, and confirm it is related to a bug in Samsung’s firmware. It’s been fairly widely reported in the press as well: https://www.androidpolice.com/latest-samsung-galaxy-watch4-update-inadvertently-breaks-some-watchfaces/

We are in touch with Google and Samsung about this and will update this thread when we have more info. Stay tuned!

3 Likes

Thank You for dropping in and updating us!

Thank you very much for responding and being very diligent to find out what code you need to fix and I’m sure we can expect an update fairly soon. By the way yours is the only watch face software I use because of the quality of the designers and your software.

Got same Problem. My Facer Watch Faces Are Not work korrekt since last samsung update

I am facing the same issue, hope for a resolution soon.

@abhisturkibng has found the workaround solution for the AOD issue. Galaxy Wearable phone app > Watch Settings > Apps > Facer. Then you have to slide the switch on the Allow background activity setting.

I have done it on my GW 4 Classic and it worked fine, but when I tried to do it on my GW4 “Active” the “Allow background activity” setting is not enabled to where I can change it. It’s greyed out, which is odd since both watches are synced with the same Samsung phone.

2 Likes

This works. :blush: :blush: :blush:

Samsung/Google added this to control apps in the background?
AND TOLD NOBODY about it for 3rd Party Face apps with the Feb 9 update!

SPREAD THE WORD!

@mrantisocialguy Nice find - this was the problem.
@Facer_Official

1 Like

They should have made it on by default. On my GW4 Classic it worked fine, but my GW4 “Active” it’s greyed out and I can’t change it even if I wanted to. It’s just a good thing that I don’t use AOD active mode anyway, but it would be nice for testing Facer watch faces on. Oh Well…

1 Like

My GW4 Classic drain battery when enable background activity for Facer. Kind of wachface does not matter.

Can confirm this worked for my galaxy watch 4 classic as well. Also, @mrantisocialguy , I absolutely LOVE your watch faces!! about 85% of my watchbox faces are yours. Keep it up, man!! cheers.

1 Like

Thank you!

@Facer_Official. Is there any news on the fixes for all the things the latest app update has messed up with WearOS 2, especially that it no longer reports phone battery at all to the watch?

I have seen no response to this on the 4 day old post (and reported directly by email): Android companion app and time speed up

You have broken the hundreds of thousands of WearOS 2 devices in the last update as the app no longer sends any phone battery data except when a new face is synced. I have tried multiple faces, I have tried switching faces, I have tried watch restarts; Only on new sync does the current battery level get send and then it is static on the watch until next sync.

This is a fundamental flaw acrous thousands of faces.

I maybe should have reported id seperately but it’s not a feature request, there is no bug report category on the forum and I can’ tlog in to help.facer.com as it does not accept my facer credentials.