Aileron 2 Gold step count and temperature readings


Firstly, thanks for the Aileron 2 Gold, it’s my favourite design and I’m very happy I bought it a couple of days ago!

The good news is - the time, battery and date all work great. Unfortunately, the steps and temperature are not working on my watch (both are stuck on zero).

There is a similar thread where it was suggested restarting the phone, watch, turning off bluetooth, re pairing the two devices & reinstalling the watch face - which I have tried without success. I can confirm location services are switched on with my phone.

I have a Samsung Gear S3 classic & Samsung Galaxy S8. I have tested other watch faces and the steps counter works on them.

If this is a known issue and being worked on then no worries. If not I would be very grateful for any help in trouble shooting please?

Kind regards


It’s been over a week with no reply. Am I in the wrong place to report a fault? I was hoping Facer would reply saying it’s logged - even if it is at the bottom of a long list (I have read two other people talk about a problem with the same symptoms but no solution, so I don’t think it’s just my watch)?.


You are wrong here. You better leave a comment on the Watchface-Page, then the creator of the “Aileron Gold” will get it. He is the one responsible for his work, not the facer staff.

I’m still experiencing trouble with all the weather data on my custom face also - it often remains blank and even if it does populate, it doesn’t update. I think there’s a wider problem here. No response to the issue as reported in another thread.

Hi @markx2donovan,

one note: Use the at-sign in front of a user’s name (@jmorga106) and they’ll get a visual blip right in their account that you posted in a message here in the community.

A few comments that may help:
there is most likely a bluetooth sync/communication problem between your mobile and your S3. I would suggest taking a detailed read through the S3 Tizen Megapost for possible solutions. I know one of the suggestions is a factory reset of your watch:

There are currently no known issues that I’m aware of with the Aileron 2 Gold face. I’ve had hundreds and hundreds of syncs of the face. The face is sold both in the Facer store and in the Samsung Galaxy store. After the contest, the finalists had all of their face designs spend several weeks at Samsung qualifying it for publication in the Samsung store. I believe only you and one other person had an issue with the face. The Megapost is probably your best reference to start with. Then the Facer support team would be next.

-John Morga

Thanks for the replies everyone.

Hi @jmorga106, its good to confirm it’s not a known issue. I will start with a factory reset of my watch and then as suggested work through the S3 Tizen Megappost. It’s a bit odd the step count and temperature readings work on other faces I have installed, but I know these things can be complex.

I’ll let you know how it goes.


ok hope it works out