Another update another set of problems: gear 3 on glaxy s8

Nothing seems to work. Wether in Wi-Fi or Bluetooth alone. Nothing syncs after the new facer update. It’s been roughly two weeks now and nothing no matter what I do gets my watches to sync.
I’ve restarted my phone
Restarted watch. Switch from one face app to facer. Still nothing.

Watch is recognized by phone.
No matter what I do no matter what face I select it won’t let me sync it

Watch is the Samsung gear 3 frontier
Phone is galaxy s8
Both are updated to the max

I uninstall the program from my watch, then reinstall it. Then I can switch faces for a while with no problem.

@dwareham okay??? What does that have to do with I posted?

@Facer_Official how about some help?

@k.b.echevarria, what watch do you have?

I am having the same issue

1 Like

@hayden the Samsung gear s3 frontier non LTE model.

Hi @k.b.echevarria, @lksulliv: I too use a Samsung S3 Frontier non-LTE version (sure S3 Classic is the same). Just recently my watch has been glitchy, not just with the Facer app. Yesterday I upgraded the software on the watch to version (254mb approx) and I recommend you do too, the new interface is improved. Backup your watch first with the Samsung Gear app on your phone and then if you’re willing update the watch software takes about 15 to 20 minutes, then and I know it’s a pain, setup you’re watch with all your apps etc including the Facer companion. Make sure your phone and watch are connected via bluetooth and if possible same wi-fi. The app works perfectly, triple tap function is working again, watches transferring super quick and for the first time I’m able to store 10 Facer faces on the watch. Best part of all of this is that the new interface on the Version 3 Samsung software is really nice. Word of caution; swipe down behaves differently but once you get used to it it really is good:
Phone is One+5 running OygenOS version 4.5.14
Watch Samsung Gear S3 Frontier Model SM-R760, Tizen, Software version R760XXU2CQK3

1 Like

How about it solves the problem for a while. It’s not a permanent fix, but it allows you to get the face that you want on your watch.

@hayden my watch is updated to the max and that does nothing for me.

@pacingpoet please leave my post alone. I did not give you permission to edit the name. Thank you


@k.b.echevarria @pacingpoet Hi, she is just categorising the topic, she is not changing anything in your contents. As you browse all the contents, they are all in categories. Hence, it is easy for the people to follow or read.

@angelodefensor the topic is support. The title said it itself. Another update another set of issues. It wasn’t her post to edit. So I’ll say it again. Don’t edit my post since its in no violation of any rules.

1 Like

You are not violating any rules at all but she is helping the readers to easily identify the post but I am just saying this, its your choice.

Then leave it alone. And let’s try to solve the issue for me and everyone else

1 Like

@Facer_Official: OK agree with above, fix was temporary and worse still now I’m totally locked out, the facer app watch sync icon is RED and nothing I’ve tried before will fix this so this is a @Facer_Official BUG, support please look in to this urgently as app for me is now functionless


yeah, think being updated to the max is the problem

I’m having the same problem with my setup. Gear S8+, Hear Sport watch. Watch icon on phone app is always red. I’ve tried everything up to and including a full factory reset on both watch AND phone at the same time, then install both apps … and nope, still a red icon. The default Facer face will load, but no other ones will sync.

So glad I didn’t buy a bunch of faces on this app, I’d have lost all my money. So called email “support” has not been any help, either, they just tell me to do the same things I’ve already done. Off to find another app. Sucks cause I’d made a handful of faces and now they’re useless.

@JillyBean1899; this is not a solution just my observations; I’ve had the same problem, tried all the suggested bluetooth on/off etc inc. full update and factory reset. Rebooting my phone a few times solved the problem of the red sync icon and for the moment syncing is working, I know this is just a work around but I’m sure given the amount of posts the facer team will look in to this problem and resolve shortly. @Facer_Official
Haven’t tried AOD settings at all as I find it drains watch too quickly.

@Facer_Official I’ve reset my watch. Rebooted phone. Now the only thing I can do on the app is look at the community. IT WILL NOT LET ME SEE ANY WATCH FACES. before that it wouldn’t even let me sync. The app has become COMPLETELY USELESS. I HAVE BEEN WAITING FOR OVER TWO WEEKS for support to help and fix and I’ve yet to receive any help what so ever.

@k.b.echevarria; Please be patient, I’m sure the recent roll out of Tizen has thrown up a lot of bugs for the Facer team. You’re reporting is a useful part of the process and whilst I understand your frustration, no fix will be instant, I’ve been using Facer for 11 months and i’m pretty sure the team will resolve the bugs as soon as they can.

1 Like