FACER Community

Battery status for phone is not updating (Edit: I fixed it. Sorta... Read last post )

Gday, Im having the problem that the battery status for my phone does not update. it either stuck or just displays “–” I have updated phone app and companion on the watch. No avail, Added galaxy wearable and facer to never sleep, set weather to 5 minutes update.Also rebooted both devices.

Weather works fine, pulse, and all other work fine. Its just the battery indicator for my phone that is borked. I see a few older posts on this issue but none recent.

Seems to have to have the same issue in beta and stable. Please help me.

Devices : Samsung Note 10+ , Samsung Galaxy S3 Classic

Bonjour, je viens apporter une solution temporaire pour dépanner le temps que facer régle le problème.
Après plusieurs test je suis parvenu à un résultat le problème viendrai de l’application téléphone et non de la montre car sur la montre je suis toujours en version 6.0.1_106392 dur ma montre (galaxy watch 4) mais j’ai rétrogradé la version téléphone je suis passé en version 5.1.72_106101 pour le téléphone (galaxy S21) elle encore disponible sur galaxy store
Et la ma montre Et mon téléphone synchronise de nouveau la batterie du téléphone tout fonctionne parfaitement tant que facer ne met pas à jour la version du galaxy store cette solution temporaire et valable .


Bonne journée à toi

? sorry mate. i dont understand a single word. Isnt it kinda wierd to reply in another language that is completely different? All i got was the version numbers. I have tried with the version from galaxy store, google play, both beta and stable. All three fail to update battery status.

I found a way to get it to post the data after much trouble.

  1. Delete the companion app on the watch.
  2. Reboot or turn off and on the watch while the phone is on with galaxy wearable and facer set to neversleep in android settings on the phone.
  3. Go to facer app on phone. (make sure it is updated to current beta from google play)
  4. Reinstall companion app from within facer. It will open a link for you on ur phone to galaxy store.
  5. Synched for one update of the data. Then its stuck again until process is repeated.

very troublesome path to get an update on the phone battery status indeed.

Some times it seems it updates if i disconnect bt and reconnect, then change watchface from the phone app. Weird behavior indeed.

The versions running on my hw not working
Phone 5.1.72_106101.phone
Watch 5.1.37.3

The versions that im running now with some success:
Phone 6.0.1._106391
Watch “5.1.37.3”

Phone: SM-N975U
Watch: SM-R770

1 Like

Much simpler way to update the battery status in the current situation.
Sync a face not currently on the watch. At point of sync the current battery status is sent. Then never, or possibly at 15 hour intervals.

1 Like

seems to not update at all. stuck again. this is not good

that works too. but not a solution im happy with as a paying customer you know?

1 Like

No. A solution is Facer fixing it and I eagerly await the next release.

I was just hoping to save folks a bunch of effort proving that transfer of phone battery stats does still exist somewhere without uninstalling, reinstalling and relinking both sides.

At the very least it will show you that it is not any of your settings amiss on either side but with the phone app once a face is loaded.
There is another workaround for Samsung users to uninstal the phone app and install the pre 6.0 version from the Galaxy store (Phone battery reporting failed at 6.0) but I also stay away from that so I cann assess the new updates as they come in.

I was hoping 6.0.2 would be here by now.

1 Like

I have 6.0.2 for the phone app and the battery issue is still there. Anyone been able to get confirmation from facer that this bug is being addressed?

The version 6.0.2 corrected the problem of battery phone for me I on GW4 and S21

2 Likes

Sadly, the issue persists for me

Galaxy fold3 and Citizen smartwatch

6.0.2 on both

Edit: and a reboot of both worked.
Haha

2 Likes

Me too. I raised a support issue via email at the start and got an automated response but nothing since or to any other queries for updates.

3 Likes

I don’t know what changed, but mine is working again now. Has been stable for about a week, so hopefully its been properly fixed now

2 Likes

It seems to also be working on all of my watches. Three WearOS and one Tizen.

1 Like

Don’t know if people are still having problems with this (I just had this problem, and found a fix). On your Watch, go to settings, apps, permissions, facer, and give the app permission for complications data. I did this and it has been working.

3 Likes

@jamie_stone2000 . Welcome to you and thanks for the Advice . On my Facer Permissions I have Location , Sensors and Storage . I see no Permission for Complications . Mine is A Samsung Galaxy Active. I understand there might be additional Permissions on another watch . Will you Please Enlighten us .

Im using a Galaxy Watch 4 Classic. However, its back to acting up again. So idk.

1 Like

@jamie_stone2000 You need to visit this link: New Information from Facer about Heart Rate & Steps - Support - FACER Community It is the text of an email I sent to @Facer_Official about this very problem. Plus I have included the answer I got back from Amber who works for Facer.

Tizen doesn’t have that permission as you have already discovered. WearOS does have it plus some. My Fossil has Location, Sensors, Storage and Receive complication data. Both of my GW4s have those also.

1 Like

Thanks for the Info on that. My watch is getting Old now. Always trusted to give us the Correct Data. MAGic. :::)))

1 Like