[BUG] S3 Frontier with S8 - Facer Auto Reverts to Preloaded Watch Face

I have a s8 and gear frontier 3. I have the black hawk series watch faces on my gear. every time I chose 1, it shows for 15-20min and the randomly changes back to a face that was preloaded on the watch. why do I have to continually reselect the watch face from "facet? thanks

@Facer_Official, @stripes15 good question and I’d like to know the answer too as I use S3 Frontier and was thinking of getting an S8, I don’t have the same problem with my S3 and One+5 setup.

The S3 needs to be reset…that did fix it for me

I did that. still have the issue.

Even I’m having the same issue…tried everything reinstalled the facer companion restarted watch and even did a reset but still no change…

iPhone 7 Plus
Gear S3

Same issue. Reported in a different thread directed to this one.

I have reported this issue to facer support, hopefully something will happen

Hi @Facer_Official, there seems to be a bug resulting from recent updates, I’m using the latest everything:
Facer App: 4.3.1_4467-(4467)
Facer Companion: 4.2.1
Phone: One+5 running Oxygen OS version 4.5.14

I’m now unable to sync facer from the phone app, sync button is permanently red, tried bluetooth off/on, both phone and watch, watch and phone reboot, even updated and factory reset the watch with no success. Push back in the community, people are becoming increasing frustrated, I’m invested but others will give up, please help

Facer App: 4.3.1_4467
Facer Companion: 4.2.1
Phone: Note 8

I have tried reset the watch fresh but still bug with the facer app on the watch.

*Animation not working on some watch face.
*Sometimes when I wake the watch from sleep mode, the facer app will auto reload to show the watch face. It won’t show the watch face instantly like before and sometimes it will just jump to the default watch face from the watch.

@ankitpuj I hear that you’re frustrated, but here’s a little bit of context. It looks like you joined this forum a week ago, and first posted about this problem a day ago.

It’s Thanksgiving weekend in the U.S. now, so the Facer guys may be spending quality time with their friends and families.

Also, this bug may originate from a Samsung update, not a Facer one. Of course Facer is more motivated than Samsung to resolve it; after all, users are more likely to uninstall Facer than to return their smartwatches. But in either case, it defies common sense to expect a major bug fix to push between Thanksgiving Thursday and Cyber Monday.


@pacingpoet, Have to agree and well put!
And to all our friends across the pond, Happy Thanksgiving!!!


Okayy @pacingpoet …sorry…completely forgot dat it’s the thanksgiving weekend… anyways let’s hope dat @Facer_Official will b able to solve d problem shortly…

Thank u

Happy thanksgiving…


Update: In addition to the default Facer face being “bumped” by the OEM faces, I can now no longer sync any faces from the Facer app to my S3. I’ve uninstalled and reinstalled both the phone and watch apps several times now.

I have the same issue with an S7 edge and my S3 frontier. Seems to have coincided with the Samsung Gear software update. Tried uninstalling everything and hard resets…no joy and very frustrating.

Also not working with watchmaker or gear watch designer

+1 with the issue

Thanks for the reports everyone, we’re testing some fixes for this issue and will update everyone as soon as we can!


We’ve created a new pinned post for support for all Samsung issues with known solutions or plans:

What about Facer and IOS issues? Having the same problem autoreverting to standard watvh face.
Tizen3 on Gear 3

@Fredo I believe the issue is from the same source, so we’ll update both versions at the same time. Updates are coming as soon as possible as we validate the bugs are fixed.

I also have the same issue on my S3 classic.

However, only in the standalone mode, when connected via bluetooth with android phone it stays loaded, standalone it will revert back to default watch face.

Facer companion 4.2.1
Android Facer 4.3.2 _4471_beta
Samsung Gear App 2.2.17082261
Gear S Plugin

Mine worked OK for a couple days but is back to reverting to the default face again. It seems that the “reversion” is time-related. If I set the face to a Facer face, it stays on the watch for about 20-30 minutes and then reverts back to the default face.