Expressions for Sun & Moon no longer work

Hi to all
I’m having a problem with expressions to have a sun icon during day hours & a moon icon during night hours.
To achieve the goal i use in opacity:
Both worked fine changing icon at the right time, but now they no longer work.
I noticed that in Creator all works at his best, but in real watches the icons do not change at the right toime.
They remain stuck with a sun icon. This happens as in my TicWatch Pro 4G LTE; as in my Galaxy Watch : as in my Galaxy Watch 3.
Here a link to an involved face with inspector open

Does anyone else have the same problem?
May be someone has a solution to this problem? Would be much appreciated.
By the way as Wear OS watch, as Tizen Watches are updated to the latest versions of firmware and apps. Galaxy 3 updated Facer Companions too a couple of days ago.
Thanks for any help

Hi, I tried now to click on “play icon” on the view of your face to launch a fast forward simulation and I see that the sun icon changes to the moon… probably a temporary malfunction?

Hi, funny thing is, when I let it run fast in preview, it changes from sun to moon, but not back to sun.

The #DISDAYTIME# tag only works on the “current” day in creator.
Other than that I have seen strange behavior with it, sometimes being 20 minutes later than sunset, or earlier than sunrise, etc.
Usually the issues correct themselves after a while somehow.
You can always make your own expression comparing current time with sunrise/sunset times

1 Like

Hi @kingDavid
Using the play icon it works, but not in real watches.
Thx anyway for your reply
Have a nice day

Hi @ThaMattie
I will check wahat you say, but usually when i start my watches in the morning i have a sun icon.
Problem is that i always have the sun icon at night too. It doesn’t change anymore.
Better to say, if i switch to a galaxy face and then back to a Facer faces the sun becomes moon, but…from then on the icon freezes again. I should switch from GWF to Facer face every time.
A real insanity!!
I only have to hope that the issue resolves itself

I’ve tried the same thing on three of my published faces. If I remember correctly I had problems of using the same expression and I choosed to used in xposition instead of opacity (I made the days going all to the left when it’s night, just to explain me better); Until now it seems to have worked right, I’ll tell you if tonight and tomorrow morning is still so.

1 Like

I use the TAGs in the Y position not Opacity and that works just fine for me

1 Like

I’ve veryfied again: I confirm that my face turned to night after sunset and turned again to sun in the morning. Try using the expression in the position :wink:

Hi @kingDavid and @icrltd4
Thanks for your suggestions. I have appreciated very much. I have tried inserting the formulas in the X or Y position in creator and i’m sure that both wil work fine in real watch too. Anyway i have a problem.
and night
in the X or Y position, both icons are visible, How can i send one of the 2 out of sight? Should you correct my formulas? Unfortunately me and mathematic we are as chalck and cheese. LOL
Thanks for a new help
I have updated my face with formulas in Y position, so you can see what i mean. One more ask, and for this i beg your pardon, if i would have sun and moon over hour 6, where now is the battery icon, how could i do?
Many many thanks

Hi diavo, This is what I use for my Weather Icon sets for Day and Night. When inserting the values for day or night in either X or Y, you only need to put in 1, X or Y, and this is the TAG I use in the Y position for Day time Icons -
This is for Night time -
The 130 at the end is the actual Y position, and I use 2 sets of Icons as you can see in this Face I made earlier (Inspection is On) -

If you want Sun and Moon Icons at the 6 o’clock position, use a different image for both, place them at approximately X 160 Y 280, and then I use $#DISDAYTIME#==true?100:0$ in the Opacity for Day and $#DISDAYTIME#==false?100:0$ for Night as in this Face -

Hope this helps solve your problem :slightly_smiling_face:

1 Like

Hi @icrltd4
Thanks again for your help. Following your updated formulas now, in the creator, all it works perfectly.
I’m eager to test how it works in my real watches.
Talking about icons at 6 o?c. I obtained what i wanted using in Y position
$#DISDAYTIME#=true?999:240$ with 240 instead of 130, just to avoid inserting formulas in opacity since it doesn’t seem to work.
Is my solution valid? In creator it seems to work with icons at 6 o?c. Of course i have 2 different icons.
Thx again. have a nice day

1 Like

No problem diavo, That should all work properly no problem now, happy to help (I’m relatively new here myself and there’s always lots to learn lol)

:smiley: :smiley: Thx, very nice and…helpful

1 Like

Well @diavo Happy to see that you’ve found a way :wink:

P.S.: @icrltd4 Star Wars is your world :smiley: :wink:

1 Like

lmao kingDavid Sir, I do love Star Wars, and Marvel as well :grin:

Thx :+1:

1 Like

Hi @kingDavid and @icrltd4
Unfortunately i claimed for a victory too soon. Rotation or X; Y position does’nt matter. The expressions no more work in the correct way. I start my watch in the morning and i have a moon icon, and at 12 o’c i still have a moon icon. The only way to change icon is to switch to a GWF and then back to FF, Doing this the icon changes and at evening, may be later than due, it changes in a moon, but…the day after if i want working icons i have to repeat the whole process. Very annoying. The strange is that in creator all works fine.
I must suppose that @ThaMattie is in the right when says about #DISDAYTIME# “I have seen strange behavior with it”
So, what to do? Probably we only have to wait for a fix.

Uhm… really strange. I don’t know what to say… you also said that you tested it on TicWatch Pro (I have it) and on Galaxy Watch, so it can’t depend on watch model in any case. In My TicWatch Pro working with X position gives me something that is really going well…

One test you can try, even if it sound stupid, could be to rebuild again the layer (not duplicating, manually copying), just to see if that specific layer is giving you problems. I’m telling you to do this because I remember that once I found problems on a layer with expression that was not working and I rebuild it from scratch and deleted the original and then it was working good. It just happened once but it happened:so I’ll give it a try…

That is strange yes, because it all works just fine on my Samsung Galaxy 46" :thinking:
All I can think of is that it might be a software bug: my Watch is still running old software, so I haven’t experienced any problems that I know a lot of other people are.