Facer 3.1.4 for Gear S2/S3 released - Introducing Your Daily Mix

Good morning Samsung Gear S2 and S3 users! We are very excited to be releasing v3.1.4 of the Facer companion app for your watch today! Lots of goodies in this new version:

  • Introducing “Daily Mix” - new day, new faces, just for you, and directly on your watch! Every morning, just triple tap on your watch to access your mix, and spin it until you find the face that matches your style for the day! Fun!
  • New AOD options: a new setting screen accessible via triple tap now offers two AOD options: “Dimmed”, which shows a darkened version of your face to save battery, or “Classic”, a stripped down version of the face in full brightness.
  • Bug fixes and optimizations

We’re very excited to be offering Daily Mix to the Samsung Gear S2/S3 users today and would love to hear your feedback on this feature and anything else you’d like to see improved in Facer.

Enjoy your daily mix!
The Facer crew

PS: Android Wear users, we did not forget you - the Daily Mix feature will show up on your watch in just a few days! And it will be delicious!

1 Like

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Let me guess, the dimmed mode can’t work on the Gear S2 due to limitations?
Or I’m missing something…

Great idea, but can the daily mix notification be turned off?
I have chosen my favorite watch face and i’m not planning to change it any time soon. So, currently, if I want to remove the notification, it’s a bit annoying to go in the daily mix and chose the already chosen watch face to exit… And than repeat the same procedure every day…

@Asterix you should be to just tap once on the face to dismiss the notification, and it shouldn’t show up after that until you use the Daily Mix feature again. Hope it helps!

1 Like

I’ve got an s3 and I haven’t seen the aod options on the triple tap screen. do you need to add it or what?
Also, the way it’s worded for the daily mix “triple tap and spin” makes it seem like you can use the bezel but when I do it switches screens (understandably as it’s the watcjface not am app) but is it supposed to do that or not?

Hi there! Can you make sure you have the latest version of Facer for Gear S2/S3 from the Galaxy App Store on your watch? The latest version is 3.1.4.0.

Once you have this version, after triple tapping on your Facer watch face, you will be able to navigate to the last section to the right and see the settings:

Regarding the Daily Mix, indeed you will not be able to use the bezel as this is something Samsung doesn’t allow third-party watch faces to use, but you will press the Daily Mix button to use your tokens. Definitely let us know what you think! We’re looking for feedback on this new feature!

Im trying to build a support channel for the creators and aspiring creators on this app. Please join at https://discord.gg/yBBgFJ3

1 Like

Thanks for the reply. It did help :+1:

I did the same thing, and the notification keeps popping up. I would rather see a setting to turn it off.

Are you using the Daily Mix feature at all? If you are not and the notification still pops up, it’s a bug on our side.

Nope, not at all. I have to tap the pop-up, then it switches to the face selector, and then I tap the current face that I’m using to exit. I’ve also noticed that it sometimes doesn’t register my taps. I’ve ended up tapping really hard to get it to register. Outside of Facer I only have to lightly tap for the watch to register. I’ve tried to switch to a non-Facer watchface and then back. It seems to help, then the problem returns after a few days.

The same thing happens to me the daily mixer pops up every day and the only way to get rid of it is to click it and to select my current watch face that I am using. There really needs to be an option in settings to turn off the daily mix feature.

I too am having a lot of issues with the Daily Mix. I just want my watch back to how it was.

I can confirm this. even if I don’t use the daily mix feature, the notification still pops up, every single day. Even if I don’t open Facer (neither on the watch or the phone) the notification still pops up every day. Please fix this issue.

Thanks for the report, a fix for this should roll out next week!

1 Like

I’m still having the same issue, receiving the daily mix notification every single day and WISH there was a way to disable this. Why not add it as a toggle to the settings page so we can disable it from our phones?

Get rid of this, please.

I can’t find facer companion app for gear s3 :frowning: direct links for the app forwards to Samsung’s website. I’m in Guatemala, can country be an issue?