Facer Creator update or change?

My Creator updated and it appears that I can’t pinch the screen of my laptop anymore to move or change the size of my watch faces. I also can’t change the alignment or position of the watch face as it relates to my screen. For instance, if I wanted to work on a detail a the eight o’clock position I could pinch and blow up the portion of the screen and it would be in the center of my frame/screen on my laptop. After this apparent update I can no longer move the watch face in my frame/screen and it makes it difficult to work on small, off center, details.

Is this just me?


Mine has changed also, but for the better. MUCH LARGER face area so you can actually see what you are doing. Also has the ability to increase/decrease the size of the face while you are working on it located in the lower left. Stuff has moved around, but after I get used to it I think I’ll like it lots better than before.


CC: @Facer_Official

Couple of minor bugs …

  • No Facer version (v5.2 or v6.x ?)

  • Wrong label: hover on ‘preview’ shows “Layer Properties” (duplicate of icon above it)


  • Save preview (square), has muddled file name/extension:


(it renders as .jpg, but default to saving as .png) That may be my browser.

FYI: I would prefer it just defaulted to: .png


I’ve not noticed that, but I have only published one face that I already had finished. I’m sure in the coming days we’ll all find more glitches.

1 Like

I love, love, love the new zoom feature. It’s so much better than resizing my browser window. The only problem is that when my mouse pointer hovers over the “+” or “-” it stops the playback of the watch, meaning if I want to watch a wakeup transition from dim to lit, I have to click play, carefully move my pointer below the window, move it all the way around and click “active”. It’s like a game of Operation.

What else is new?


I also find that the watch constantly stops playing even at the slightest move of my cursor. I think Facer should change that to only stop the watch if I click stop.


The old version did that for me just by hovering my mouse over the elements on the left below the active dim choices. Always had to be careful moving the mouse along that side of the creator.

1 Like

Right, but have you tried the new version? It’s not just the elements now, it’s practically the whole screen.

Not yet, I have several faces already made and I need to get them published before I make any more.

I like the new zoom feature because it allows a new level of detail for face makers. But the trade off- no longer being able to manipulate the canvas left, right or up down in my field of view, to me is not worth the extra magnification. As it stands right now the zoom feature only helps me if I want to zoom in and influence something in the middle of the face. I don’t have the ability to zoom in and then pan up, down, left or right to the outer edges of the watch face.

I hope this is something that gets fixed. What’s the use of amazing zoom if I can only use it in the center of the face?

1 Like

You might want to get yourself a USB mouse to add to your laptop. I have a mouse and I can move the canvas left, right, up and down using the scroll wheel. My mouse allows moving sideways by pushing the scroll wheel left or right.

I have the canvas set at 250% for both screen shots.


Hey all!

Thanks a ton for these reports. We’re indeed deploying some significant changes to the Facer Creator this week and it appears some bugs slipped through the cracks. Our team is on it and we’re expecting a number of these issues to be fixed in the next few days.

Thanks so much for your patience, and please don’t hesitate to share more bugs here - we’re monitoring this thread for this purpose.


Thanks a ton for the detailed report @andrew.dowden! We’re looking into all these issues and hoping to fix very soon.

1 Like

@rshortt6 sorry about that - it’s likely an incompatibility between our new zoom feature and the pinch gesture of your laptop. Can you share the model of laptop you are using? We’ll try and reproduce this and fix it as soon as we can.

1 Like

Some changes were for the better yes but overall it’s made Facer very unstable. Stability was iffy before and it’s even worse now- Facer is the only thing that can crash my computer.
That [performance] is the biggest problem right now, though there are numerous small bugs. For instance, sometimes I place elements with precision, come back to edit the face later in the day and various elements are off by several pixels. The timeline slider sometimes doesn’t load and becomes useless. Where did the save button go? Now we have to send the face to a watch to save it? I think that’s the case, not very intuitive that. There are some other small issues but are they being looked at? Haven’t seen any Facer team community activity in a long time now.
I realize the crazy times we’re all experiencing now are likely having an impact with the Facer team and I hope that they and their families are all ok. I also hope that these bugs get worked out soon because they’re forcing me to seek an alternative platform in the meantime :frowning:

What browser and model laptop are you using? I’ve had no problem using Lenovo ThinkPads running Windows 10 v.1909 /Edge Chromium.

1 Like

Using a desktop pc with Chrome for the most part but these issues led me to trying Edge. Edge has more display issues but performance is better. Chrome is a hot mess. PC has an Nvidia 1080 8gb gpu, 32g ram, i7 7700K cpu and ssd drives. It handles the latest games at max settings with ease, along with fairly huge image files in Photoshop. Drivers are up to date as well- I checked as many things as I occurred to me.

1 Like

Annche has improved for me, even if, as already said by @pandaKrusher passing on (+) (-) it stops turning the clock.

@greg1 the save button has moved to the top of the screen. It’s a small black disc icon. And to @rshortt6 I can also +1 that my mouse’s scroll wheel pans the editor view.

Adding one more gripe @Facer_Official - when examining someone else’s watch, the text field that says “Inspector Mode Your changes will not be saved!” is covering up the new location of the rocketship icon. The only way to look at someone’s layers is to inspect the element and delete the popup from the code.

1 Like

Blockquote[quote=“rshortt6, post:1, topic:50082”]
My Creator updated and it appears that I can’t pinch the screen of my laptop anymor

lol @ “My Creator” Well He is all powerful you know.