Facer Pro Creator not loading face to edit

So I go to my desktop and load facer Pro Creator website, then I go to create a watch face, then I duplicate a watch face I want to make premium, then I hit the edit button on the copy and it’s all it does is go to the Creator Pro Design page and has the loading symbol, but it never loads the watch face it just keeps the loading symbol animation!

Even if I try to edit a watch face the same thing happens. It goes to the Creator Pro Design page and the animation that shows you that it’s loading just stays on it doesn’t load the watch face no matter how long you wait.

I have an I9 Windows desktop with 32 GB of RAM, 100mbps connection. 8 GB graphics card.

So I know I’m not underpowered and I know my connection is plenty fast to load the page like it used to last month you know within a few seconds.

Anybody else experiencing this.?

Perhaps your servers are overloaded and you need to expand your Hardware or bandwidth?

This is now anytime I want to edit a watch face it doesn’t load at all the animation that shows it’s loading is the only thing I see and it never loads the watch face even if I walk away for 20 minutes.

What’s going on?

Can’t be my end it’s got to be your end.

1 Like

You have hit the Nail on the head . It is not your equipment . It is the Connection to the server . It may not be the Facer server itself but the Priority given allong the way . When it gets sticky here in he UJ I sync stuff to my watch from my phone . That is always the most reliable . Some Syncs are almoust Instant Some are a goid few minutes m I know that a Face with very heavy resources can take a bit of time . Do a test with an Eco Basic . Also how much room is ther on your watch . When Things get sticky I clear the lot . I have 1 Facer and one WFS . Things work realy well then .

Your PC is definitely powerful enough, that is out of question. I know there should not be any difference, but still, did you try another browser to load that page?

1 Like

Well I use Chrome now I don’t really like using the Microsoft browser I do have Firefox I could try that.

1 Like

Even when I go to design a new watch, the page might not even load a blank. Sometimes I just have to keep refreshing the page until it loads. I also check my internet connection to see if that’s slow and it never is.

1 Like

As Russel says.

It’s been discussed here: when you cannot sync from computer:

  • save watchface
  • sync from phone
  • now you can sync from computer again
  • don’t ask why, it’s a mystery, only Marvin knows the answer :shushing_face:
1 Like

That’s not the problem.

The problem is and still is by the date of this post when I go on my desktop to work on a watch face with facer Creator Pro it takes forever to either load a blank or a previously copied watch face that I want to have a second edition too. Or it doesn’t load a previous face that I just want to update.

That’s not the issue.

Facer Creator Pro on my desktop does not load blank watch faces or previously created watch faces for editing.

I don’t have a problem loading a watch face from the app on my phone to my watch.

Sometimes there’s an issue from my desktop to my watch when I’m testing out a design but it seems to load when I do a few things with my OS app or my Facebook app. But it’s not consistent either.

1 Like

I do not see anthing in the Faces on your profile that woul Load up the memory of the watch . Have you tried A test with a brand new simple Face . Is it just when you want to rework a previous publication . Are you trying to work on the Duplicate that you did not publish or rework the actual publication . next question is your Internet connection good . What is the age of your PC . I can work on Faces on my TABLET but is is not easy and Terribly slow . As you say remarkably inconsistent . I do most of my work on a Budget Laptop running Windows 10 Home .
I have worked on 100 layer Faces with no problems . Somtimes when Faces get that loaded the saving takes a bit of time . I detect no difference when I work on Faces with PRO Tags and Complications .

I’m not talking about syncing a watch face from either the computer design app or the facer phone app.

I’m only talking about either starting a new watch or editing previous face on the facer Creator Pro Design program.

I have a Windows 10 I9 computer with 32 GB of RAM 8 GB graphics card 1TB SSD C drive 2 TB internal D Drive and 2x 4 TB external SSD drives.

This all started about maybe 2 months ago where when I would want to start a new watch face it would stop loading a blank watch face or it would stop loading previous watch faces.

I would have to basically go through 5 or 6 or 8 or 10. Refresh on the pages before it finally would load

This has nothing to do with syncing a watch face from the computer to my watch or for my face or app on my phone to my watch.

This has everything to do with when using the Creator pro software nothing loads until either multiple tries or I just shut my browser down open it up again and try again and then sometimes it works and sometimes it doesn’t.

It’s frustrating to say the least.

I mean on my end it feels like there’s a blockage somewhere with the servers on facers end where they’re just not loading blank. Faces to start a new watch face or previous faces to edit

1 Like

OK . I am getting it into my head your issue . I ask questions as an indication of performance base on what my experience is . I must ask Are you using the WEB Creator not the downloaded one . I must ask have you tried a different browser . Have you tried clearing the Browser Cache . Taking into account you will have to log back in to some Apps .

1 Like

Try deleting your browser cache (files and images). If that doesnt do trick, delete browser cookies (will will have to log in again to websites). You probably got a stale cache.
You can also try logging into facer creator from an incognito (chrome) session, or private session, to see if it is related to caching.

1 Like

How long has it been since you submitted your support request? If you have not resolved this, use the same ticket # and send an updated request, please.


Didn’t work.

Same with switching to Edge

1 Like

I have not put in a support request, just this topic tread

1 Like

Does this happen on creating a watchface from new (not a duplicate)? I once had issues where i was unable to save duplicated watch face and ended up starting again. Also have you got a tablet you can try opening the face on and saving? Finally, if you put a link to your watch face and make draft inspectable, others can try opening it.

1 Like

It happens on NEW design, edit on a published watch, and on a duplicate.

I have a new design still trying to load, and an edit on a published watch. over a minute now. Still trying to load.

I use a desktop DELL XPS 8390, i9 multi-treaded CPU, 8Gb GPU, 32GB RAM, 27" monitor,
100mbps internet speed, ethernet hard wired, not WiFi.

I don’t have or use Tablets or Laptops.

Link to a face with inspection mode on. (TOOK 10 page refreshes before it loaded for editing)



It opens instantly on my tablet in inspection mode. Im not sure why you are having so many issues. Could you have a virus on your pc? Who knows… if it were my pc i probably would reinstall windows on it, but you would need to backup all your files onto a portable harddrive. I dont know what else you can do on that machine, except scan for virus maybe.

I have a good virus program that I scan my computer regularly for virus in it is updated also for all kinds of malware and stuff. So it’s always showed my computer to be clean

1 Like

Well, you have tried clearing browser cache and cookies to no avail.
If you have any browser extensions enabled, turn all of them off and see if that helps.
If it does, you can then try to identify the extension causing issues by turning on 1 at a time and testing again.
Failing that, you can try uninstalling browser and reinstall again.
Running out of ideas! I hope you can fix it.
I use samsung ultra 12.9 in tablet. Its fantastic!
If you have a samsung phone with dex capability, you can also use that.


I presume you do have WiFi . For some stuff your Watch has to connect to the internet . Did You say you tried Chrome . At one stage I had to use Fire Fox . I can not remember what was going on .

1 Like