Faces wont sync with Fossil watch on iPhone 12


i have just moved from an android to IOS using the iPhone 12.
Setup done as required. Wear OS, BT shows that the phone and watch are connected.

Am able to load a face from the Daily Mix. However, when i try any other face, the Facer app on the phone shows that the face is sent, but nothing happens on my watch.

Please help.

I’ve read about this issue on this thread Help needed with Facer app using iPhone. They suggested turning off bluetooth and syncing with WiFi instead.

Thank you. Tried that too, no luck.

It sounds like you need to get help from @Facer_Official on that one, you can contact them at: Submit a request – How can we help? or email them at: facer-support@little-labs.com

iPhone 12 pro here. Finally can get my QR CODE and now Facer says sending and nothing ever sends the default three Facer faces are the only choice I get. Missing the functionality and preferred faces. Premium subscriber. Have deleted all apps and done factory reset on both phone and watch to reinstall them. Still no luck.

Same problem here. I have iPhone 12 pro Max and Huawei watch 2. The devices are connected but I can’t send watch faces. If I tap the send button it will show “sent” but nothing happens on my watch and I can only use preloaded faces and the daily mix ones.

iPhone XR and Fossil Q HR watch connected. QR code read and iPhone and watch connected but can’t sync any watch facers. Have tried re-installs and restarts on both devices and also making sure both apps are up to date.

Same issue here. Contacted support. No one answers.

Facer are aware of the issue and have Google looking for a fix, see here for latest updates: [KNOWN ISSUE] QR code shows SERVICE_UNAVAILABLE on WearOS watches connected to iPhones

Hi all, I have exactly the same issue. I noticed one thing though. I have a new Fossil Gen 5 watch and when I look at the Settings on my watch and then tap on Power by Facer I see User: Guest and Status: Standard. Is this normal? Somehow I have the feeling that my watch doesn’t know I’ve got Facer Premium.

Anybody else seen this as well?