Facing syncing issues with galaxy watch 4 classic

Hello friends i have a galaxy watch 4 classic and i am facing syncing issues when i try to sync it says checking facer companion app status on phone and stays there nothing happens ahead of it…

First select Facer in the Samsung Wear app as your watchface. Then wake up your watch and make sure it is showing a Facer watchface. That should be enough for the Facer app to realize it the watch is actively using Facer and allow you to sync watchfaces. WearOS 3 seems to be a little picky about how it communicates between the Facer watch and phone apps for some reason.

Did that still shwoing “Checking Facer Companion App status… on phone

Touch the watchface and make it recognize the touch. That should jar it into communicating with the phone app. You might also go to the settings page (3-line hamburger menu on the top left) and make sure you have the correct watch selected. On a recent Facer update that might have changed for some reason. If nothing else reselect the current watch again so the app knows you have it selected.

I touched the watch face and on phone I reselected the watch still showing same message. I did a full reset of watch removed facer both from watch and phone and reinstalled it all over again still same error

When i tap few times i get a qr code on watch but i am not getting any option on facer app on phone where to scan that code

That QR code only works with Apple watches. I’ve never found a use for it in WearOS. Is your GW 4 Classic connected with your phone? If it is and your Facer watch and phone apps are both set up correctly then you need to contact @Facer_Official’s Facer Support system at: https://help.facer.io/hc/en-us/requests/new . They will want you to include the watch brand and model number, the operating system version plus the Facer app version you have. Also include a detailed explanation of the issue you are having.

yes it is connected successfully. i have selected facer watch face aswell but not able to sync any watch face as i get that message which i said earlier. CHECKING FACER COMPANION APP STATUS

Check if you did this:


*
*
*

*
*
*

*
*
*

*
*
*

did this still no luck brother…sent email to facer team regarding this they told me all the steps which are available online done that lots of times but no sucess.

What country are you in? There are some countries that the United States has a technology embargo against and if you are in one of those countries that might be the source of your problem. I know for sure people in Iran and sometimes China have issues with Facer since it is a U.S. company.

i am from india…to be specific from MUMBAI.

was using it on galaxy watch 3 had no prob at all…upgraded on watch 4 classic and not able to sync atall…

I still think you are doing something wrong, missing something simple… I know for sure that Facer works on watch 4.

Do you have bluetooth connection ON?

Samsung Galaxy Watch4 - Turn Bluetooth On / Off

  1. From the watch screen, swipe up to open the apps screen.
  2. Tap the. Settings icon. .
  3. Tap. Connections. .
  4. Tap. Bluetooth. .
  5. Tap. Bluetooth. to turn on or off . The device is visible to nearby Bluetooth® devices while Bluetooth is turned on.

Of course, bluetooth has to be ON also on phone.

yes bro bluetooth is on that why i am getting a basic Facer Watch Face on watch but when syncing it showing that message

Did you set Facer as the watchface?

Phone: galaxy wearable app - watchfaces - select Facer

yes i did still no luck

I don’t have any more ideas.

thanks brother for your ideas…still waiting for facer team to reach out to me…

Are you logged in?