[FIXED] WearOS/iPhone users - QR code showing SERVICE_NOT_AVAILABLE

Hey Facer Team,
It has been almost 2 long years but this issue not been solved. I can’t generate the QR Code because of the “SERVICE_NOT_AVAILABLE” error. My Asus Zen Watch 2 Gen is paired with my iPhone Xr. All updated at last version.
Please Help !!

I have this on my watch as well and it’s two days away from nov 2020. Both updated to the most recent apps version. Watch (fossil Carlyle gen 5) and phone.

1 Like

I just got my Fossil Gen 5e and I have an iPhone X-- I also cannot generate the QR code on my watch, it says “service not available”. I’ve disconnected and reconnected my watch, reinstalled the app on both my phone and watch, restarted both devices, and made sure all my apps are up to date. Nothing has worked. Hard to believe this problem has been going on for more than 2 years and Facer has not fixed it yet. Please help!

Hi @rachelh47,

Thanks for your post! There doesn’t seem to be a widespread issue related to this as most users are able to user Facer with an iPhone today. The issue reference in this thread was resolved by Google a couple of years ago.

If you are still having issues, could you send us an email at facer-support@little-labs.com? If you already have done that, please feel free to share your ticket ID # here and I can escalate internally.


Hi. I have to Change From android to iphone and Many issues on iOS 14 With Android Wear devices.i have issues on qr code scan as SERVICE NOT AVAILABLE and Facer iPhone App sent but not appears on iPhone. I tríed restarting watch device but issue persists You need to test Facer App on watch wear sync with iPhone iOS 14. Please fix it. My watch is sad without facer faces.

Hi @darkneszalex @rachelh47 and others on this thread,

We’ve identified the issue, which is new and was introduced by a recent WearOS update (WearOS Home App which was released by Google on some watches on October 29th. We have notified Google of the issue and are working with them to resolve it.

We will open an official thread for this issue to share updates about it.

Update: official thread is here: https://community.facer.io/t/known-issue-qr-code-shows-service-unavailable-on-wearos-watches-connected-to-iphones

I’m having the same issue with my iPhone 11 Pro Max on a fossil gen 5, can’t generate QR code service not available error.