Galaxy Watch4 Issues

Installed the Facer watch face I created on my Watch4 and have these issues:

  1. Steps data does not sync with Samsung Health in the direction of Samsung Health => Watch
  2. There are leading zeros on the hour for sunrise/sunset times even though they are not there on the Facer design screen
  3. Custom font colors do not match the design screen.

Any ideas on fixing these issues?

I don’t have the Galaxy 4 (tempting though) so I can’t comment on all of it, but the leading zeros for sunrise/sunset times are there on the watch with regular WearOS watches too. It’s one of a few things that show up different on the watch than what you see in the creator.

Curious about item 3, can you describe that more? It’s is it the theme picker that’s setting the color or you’ve defined a single color for a text layer in creator? One simple thing to check, make sure you set that same color for dim mode too or it defaults to white.

1 Like

Thanks Kvansant!

For item 3, I have a watch face that displays the temperature in a custom color depending on the value of the temperature (colder temps are in blue, warmer in orange/red). It is currently 73 degrees here and it should display as yellow, but instead it’s displaying as green which is the color for the cooler (60s) temperature. It worked fine on my Watch 3 but started doing this on the Watch4 with no changes to the design.

definitely sounds like a bug specified to the new OS then. If you haven’t yet, best thing is to send an email with detailed info to Facer support. I know they’re trying to track WearOS3 issues.

2 Likes

To point 1.
I can only guess, but Samsung probably does not send s-health data to third party apps like facer, so they have to measure on their own. If you sync the app after doing some steps in the day, the data wont match. Maybe let it be there longer, so the midnight reset syncs the both measurements. Or does not show steps at all? Did it sync with the S-health on the GW3?
To point 2.
If it is a bug, maybe there can be a workaround like $#DTIMEFORMAT#==24?#WSH#:PM#WSh#$:#WSmZ#
Can you check it on wear OS watch? I do not have such yet.
To point 3.
Did you set there some colours for a temp ranges or do you mix the colour using opacity of overlaying text? Opacity may not work same on different watches or new OS.

I think I have figured it out!! The formula I had in place for my GW3 needed a small change to work properly on my GW4.

Before:
$#DISDAYTIME#!=1?100:0$

After
$#DISDAYTIME#!=true?100:0$

After I changed the “1” to “true”, the formula worked properly again. Maybe something specific to the different OS?

1 Like

glad you figured it out! I have always used true/false instead of 1/0 It’s possible I read at some point that some watches handled it that way but not the other. Can’t remember for sure if it was specifically this, but definitely there are some expressions which may behave a little different in Tizen and WearOS. Though it’s usually only when you’re trying to do something a little more involved.

2 Likes

Using true/false seems to be the safest option. If you want to use 0/1, you can use parentheses, that turns everything into numbers:
$(#DISDAYTIME#)!=1?100:0$ ← using parentheses makes it a number
$#DISDAYTIME#!=true?100:0$

Making it a number also opens up other possibilities:
((#DISDAYTIME#)*100) ← although this would be ==1, instead of !=1, but you get the point

2 Likes