[Help] Facer No Longer Works After Samsung Update for Gear S3

Samsung updated the software on the Gear S3 Classic. Since the update Facer no longer works on the watch. The sync process goes about 3/4 of the way and then stops. No watch face ever loads. I’ve designed over 200 watch faces which I can no longer access on my watch. Please look into this and see what you can do.

I am having the same issue after last night’s update. I can’t select any watch faces as the button is red. Nothing happens when you press on the button.

Thanks for all the postings on this board. Unfortunately, I don’t know where to find all the information you requested in posts. I didn’t even know the Gear S3 had anything to do with Tizen, no less the version; however, I did follow the recommendations in some of the posts, specifically, I turned off bluetooth on my phone & watch, uninstalled the Facer watchface from my watch, Turned bluetooth back on, connected my phone to my watch, reinstalled the Facer watchface on my watch, and synced a watchface successfully :slight_smile:.
Thank you.

1 Like

After updated tizen 3 just uninstall facer on the watch and reinstall thats all. After that its working like before


it does not work for me. I tried to uninstall but nothing. in fact when I apply fazer’s watchface after a few minutes you set the basic one alone.

I am having the same problems since my Samsung Gear 3 update last night: I can’t load Facer on the watch (bar gets about halfway and then it just defaults back to the basic watch face), and if I try to push a watch face from the mobile app the button is red and does not work.

Please help us. :slight_smile:

Nothing seems to work. Wether in Wi-Fi or Bluetooth alone. Nothing syncs after the new facer update. It’s been roughly two weeks now and nothing no matter what I do gets my watches to sync.

Uninstall at the watch, reinstall from your phone. It will work for a while.

@dwareham I’m not looking for a temporary fix. I want a permanent fix.

Not to mention that when I did what u suggested. I can’t see any watch faces and I can’t log in to the community via the app.

@dwareham yeah … except it doesn’t work. I’ve even done a full factory reset on phone and watch, still won’t work.

1 Like

@JillyBean1899 are you on the Gear S2 or the Gear S3?

I reinstalled software and it worked enough for one face change now button stays red and I can’t change anything again

Mine did the same thing. I found out I needed to download the facer companion app for the gear 3 in addition to the regular facer app. Now it is back working. Yeah!

Thanks for updating us @cmarotto07 - if you have the red button issue, you can try switching away from the Facer watch face on your Gear (to any other default face) then back to Facer again.

Note we’ve also collected all issue updates and posted them in one location to make this a bit easier for everyone. Thanks for bearing with us as we work out the issues!