iOS Facer Companion Update Failed

I have tried no less than 20 times to update the app with the most current update from 2/22/18 with no success.

Hi @hceteht,

Can you uninstall and re-install it? There may be issues updating from 4.2.6 to 4.2.7 that we working with Samsung on.

Deleted Facer app and then reinstalled. No change. Download/install of update still fails.

@hceteht - Can you share what error you are getting when you’re trying to install the app from scratch after the previous version was deleted? If you could share a screenshot, that’d be great - we’ll forward it to Samsung.

Those are all the screenshots when trying to apply the update. As you can see, there is no “error” given aside from the Download Failed at the bottom of the screen.

@hceteht are you able to install other apps than Facer? The connectivity between iPhone and the Samsung watches is sometimes a bit finicky.

It appears that I have the same issue. iPhone 7+ paired to Samsung Gear S3 running Tizen 3.0.
IOS Companion app listed on the Galaxy App store as 4.2.7.

The download and install progress runs to completion on the phone (reaches 100% and closes.)

The watch refreshes the face and optimizes Facer.

However, the settings screen on watch shows version and the update icon is still visible on the phone.


I don’t even get that far.

I’m on iPhone X with Gear S3 Classic and Tizen

I have no issue installing other apps

I’ve been wondering about the recent Gear S app update to 1.6.18. Under 1.6.17, I had some standalone faces (not Facer) that did the same thing. I had a couple left over that I had given up hope of updating. I just tried them and they updated successfully, but not the Facer IOS Companion app. So, 1.6.18 seems to have resolved those update problems. Maybe there’s still a residual Gear S App issue independent of the Facer Companion app?

I’m trying a few other things. I also have a Huawei watch paired to the same iPhone and will see if that updates the companion app. Another idea is to seer if I can update the companion app directly from the watch instead of the phone, but so far I haven’t been able to locate it from the watch-based app store.

No luck with the direct watch-based galaxy store.
However, I think the issue is the companion app rather than Gear S app.
Twice, the 4.2.7 was sent to the watch. Each time, the watch face went black. A long-press allowed me to re-select Facer and the face came back. Whew… I thought I had bricked the watch.

I also have an older Gear S2 that I’ll pair to my wife’s iPhone X to see how it behaves.

Hard to know where the issue lies. Every time I’ve ever contacted Samsung about any watch issue, all they want to do is blame it on iOS/the iPhone.

Still no luck updating Samsung watch IOS Companion app to 4.2.7.

FACER SUPPORT… Any other ideas that we can try or additional information that you need to troubleshoot?

Just curious as to what we’re missing in 4.2.7 compared to the that is currently installed.

Thanks again for a great product. Looking forward to resolving this.

Hi @richpdcomm - can you try uninstalling the app completely from your watch, and then installing it again?

I hate when this is the response to fixing things though.

This may be needed due to some architecture changes in the way Facer is distributed to users :frowning: It’s a limitation of the Galaxy App Store. Let us know if that works!