Just Launched! User's Preference Tag for 12/24 hr Time Format

#Just Launched! User’s Preference Tag for Time Format
Want to maximize your syncs? With our new #DB# tag, your watch can appeal to users of either the 12 hour OR 24 hour clocks! Now you can design your watch to check a user’s preference and use the time format they prefer.

Try it out today! You can even swap this tag out in your old watches - instead of using #Dh# or #DH#, use #Db# and give the power to the people!

Unless you have a really awesome reason not to, we strongly recommend using the new #DB# tag over the other hour tags if you are displaying time!

For instance…

Let’s pretend it’s 1 o’clock, pm! (That’s 13:00 for you 24-hour-ers)

If you use the #DB# tag on your watch, a user with the 24 hour preference will see 13:00, while a user with the 12 hour preference will see 1:00.

Kumbaya, world peace begins.

I changed the hours tag to #Db#. It works great in the creator but on my watch it shows 24 where it should be 0. :frowning:

@FalkWussow Sorry about that. Our documentation is a bit unclear on the use of the #Db# tag, we will update it as soon as possible. For now you can change your tag from #Db# to #DB# and it should work as intended!

Hey Tim, thanks for your quick reply. I didn’t even realize the difference between DB and Db. :blush:

With #DB# I’m now getting things like 0:35 pm which should be 12:35 pm. :confounded:

@FalkWussow Is this on your device or on the website?

The creator on the website shows DB and Db correctly. I tried on my Sony SmartWatch 3 and the ASUS ZenWatch 2. There it shows this confusing behaviour.

For now, I use $#Db#>=24?#DB#:#Db#$ to get the correct display:
The wrong 24:xx now shows as 0:xx and 12:xx pm stays 12:xx pm. :wink:

@FalkWussow Thanks for bringing this to our attention! We’ll post once we have a fix ready.


Is there any way to use AM/PM with this option? (So that AM/PM only shows up on 12-hr format, and not 24-hr)

I ran into an issue with #DB# - at noon, the time is displayed as 0:00 in the 12 hour format. If I change it to 24 hour format, it displays as 12:00.

For now I switched back to #Dh# until the issue can be fixed.

I’m using a LG Watch Urbane.

If you set the time 12/24 and does not work, then try to clear the cache and data of the app Facer on the settings of your phone. Attention will need to redo your login app Facer but it works

How can I use this tag for rotation in an analog version? Or is there another tag?

You can use $#Db#<=12?#Da#:""$ to show AM/PM and hide it when the hour more than 12 (if the user choose 24 hour format).

That’s not really a solution. Users that have selected 24-hour time don’t want to see “AM/PM” ever.

1 Like


This isn’t very useful without a way to hide AM/PM for users using 24-hour time. If you want people to switch their faces to use #DB# and #Db#, you really need either a version of #Da# that hides itself in 24-hour time or another tag that returns true or false depending on whether the user has selected 12- or 24- hour time.


This is a simple approach to being able to display current time in a single field, per the user’s (watch-wearer’s) regional (or social) preferences.

That said, this does NOT address how that would be applied to a more complex presentation for time (different fonts, size, layout, graphics, etc.).

Any solution should BOTH support the designer to determine the user preferences AND determine whether the design (as published) supports all or only specific variants.

I am working on a possible solution …

As others have mentioned, this isn’t working at all as expected on my Gear S3 Frontier. There are no 12/24 hour time settings on the watch that I can find. I believe it takes it from the phone, which is 12 hour time. But with #DB# or #Db# (FYI, your tags page only shows #Db#, not #DB#), the watch face I’m making shows 24 hour time on my watch. So I guess I have to do two different versions of the face if I want to share it?

I am having an issue with this option on 2 of my faces. It shows that the 12/24 option is available, but when a user opens settings, the only option showing is temperature preference. No option to change time. Any ideas? The watch was just saved yesterday.