FACER Community

[KNOWN ISSUE] Step counter issues on Pixel Watch, Galaxy Watch 4, and Galaxy Watch 5

Hi all,

The issue:
As many of you have reported, we are seeing some issues with the step counter on the Pixel Watch, Galaxy Watch 4, and Galaxy Watch 5 devices. These issues are sporadic and result in the step counter either being stuck at 0, or no longer updating after a certain point.

Our team is investigating this issue with Google and Samsung, and the current understanding is that WearOS starts failing to send step counter updates to Facer after a little while. The cause of that failure is not yet known but actively investigated.

Known workaround:
This issue appears to fix itself after restarting the watch.

We will update this thread as we learn more and are hoping to have a fix for this soon. Thanks for your patience!


While dealing with Samsung and Google, can you please inform us will the live heartrate on Watch 4 and Watch 5 ever be solved?
Thank you!


I have the same problem with my heartrate showing as zero with any Facer face on my Ticwatch Pro 3 Ultra GPS.
Non-Facer faces do not have this problem.

Thank you! Any suggestions if restarting doesn’t help? I’m disappointed that I purchased a watch face without knowing of this issue and now it doesn’t count steps (one of the main things I loved about it!).

1 Like

Make sure you have updated Facer both on watch and phone.
Few days ago new update has rolled out and problems with steps/heart have been solved.

1 Like

Same problem on Fossil Gen6, not fixing after restarting the watch

Just wanted to report. I have the latest December update to my pixel watch and the step counter still isn’t reporting for the facer watch faces. Standard pixel faces are fine.

1 Like

Same as above. Latest OTA and steps still do not report correctly. It’s pretty awesome not being able to use my fav watchface due to this issue. Hopefully it’s actually fixed soon.

Any update ? Seems like you guys have been aware of this problem since November 2 … I’d think after a month , there’d be some update … Asides from restarting the watch

The biggest problem is on the Google end of it. Google has always treated WearOS like a “redheaded stepchild” and not like they do Android. They are still trying to iron out Pixel 6 phone bugs even though the Pixel 7 is out.

1 Like

I agree. I also think that Google cannot or do not want to keep up with Samsung. Or they just don’t care.

1 Like

Same here any update I just paid for app and am disappointed that it’s not working as advertised.

you didn’t describe the problem, steps count has been fixed, it should work fine.

Did you give all permissions to Facer (on watch)? By default some permissions are denied.
watch: Apps-permissions-Facer- allow all

I’m having an issue with Step counter on my Pixel Watch. I am getting heart rate though. All permissions have been granted, Facer app is up to date, watch restarted several times.

What am I missing?

and, as if by magic, all I had to do was sleep on it. Mysteriously fixed overnight


maybe the watch was tired and needed the sleep.

Sleep or not - the problem still exists. I downloaded a new face from one of my favorite designers, “MrAntiSocialGuy” and it’s not working for that one either. It’s definitely an issue between WearOS and Facer as none of my non-Facer faces seem to have the problem. Today, the step counter counted nicely to 815 and stayed there even though I continued to walk and Google Fit counted up to 6475. I restarted the watch and the step counter went back to zero and stayed there. It’s definitely not the designers’ problem - they do great work.