OK I was challenged to create a SHIELD watch in an hour-ish

He said that in 6 months he had not seen the sane logo from the series,
Pretty certain I got a code yellow face done in the hour and added a randomiser to the top threat level text I can run the additional layers from but for now there is just one,

I have used an image backgroud and will thank the author f the image.
What I have is:


That’s great, I love it, but you need to change the size of the text at the top, it’s not fitting it all in, I see “…” at the end.
Oh, and welcome to the Community…I certainly remember Fisk :grimacing:

1 Like

I’d forgotten to put brackets ruond the wakeRand expression


Can’t understand why only 2 people have liked this, very unusual :thinking:
You’ve done a decent job Rob, well done :clap:

1 Like

Possibly it was because it was not yet published.

I realised I could not use wakeRand as I have 3 different layers for the 3 colours and they would randomise differently. Also I cannot find a way to set a condition based on the value of another element.

I used (round((#Dm#/60)*100)) to generate a percentage based on minutes and $(round((#Dm#/60)*100))>65?100:0$ to turn the layers on and off for the colours.

Rotation of the direction arrow use smooth hour rotation as it gives 0-359.75: #DWFHS#


@icrltd4 Gizmo was just surprised for a swiftly developing beginner you did not receive a bit more Kudos here. Some times it is like that.

You could randomise the wake number but it is a deminishing return as it is always gong to be smaller. As a Premium Pro I suppose you could set a variable.
I will invite you to look at ((accelerometerRawY()) *16) gives you a number from 0 to 100 lifting you wrist to vertical. The X axis works differently and snaps back to center after 3 seconds. Plain (accelerometerX()) drifts back as well but takes about 10 seconds.
You might have some Fun with that.
Keep Publishing.

I got his to work


Remember to simulate Wake stuff you have to have the Time Machine Running and the Active Button . You don’t have to go to Dim First : )



I thought each element would generate its own number.

I just did a test on my scratchpad draft:
Created text with (wakeRand(0,100))
Duplicated it twice.
Used DIM/ACTIVE to switch (didn’t understand your time machine bit, sorry)
They all changed to the same number.

This suits my needs perfectly but I do wonder what you would do if you needed multiple elements each generating a different number.


Yeah sorry a bit confused here. It is the other rand that needs the Time Machine running. IE pressing the play button. But you will probably not be using that yet. The way you are going at the moment you will have something sorted soon.


Aye, All updated. The direction uses (wakeRand(1,360))

I thought as the above worked independantly from the percentile one and you needed 3 different random numbers beween 1 and 100 you could use:

I thought it would generate different numbers as they were different ranges but no joy. There must be a fixed seed each wake.


You could make 3 pseudo random numbers by multiplying them and use modulus:

This could generate something like 22, 84, 48


Oh the Magic of Modulus. Those are going in the Bits Box.

1 Like

This is a great watch face. I am having only one problem. The weather temperature isn’t updating at all on my Samsung Gear Classic S3 Watch. I’ve checked the settings and even ran the update feature on both my cellphone and on the watch but temperature still doesn’t update. All I end up seeing is: F - -
It isn’t the watch because other watch faces do update the weather.

1 Like

Lots of people have been having trouble with weather elements. After a bit of reading that all permissions were correctly set I found that installing OpenWeather on the phone helped.

This was my main post for info: FACER no longer supports weather? - #18 by russellcresser

I still don’t seem to get wind speed at all though.


Are you talking about Shield V1? I will test it : )

So it works for me.

Link for Open Weather on the Google Store.

1 Like

I find that usually, if someone sees … where any text should be, then that means that the text cannot fit into the size of the box created for it. Simply unchecking the Fixed Width little box can normally resolve this, but sometimes the actual Text Size needs to be adjusted as well.

Where did you see this on this face so I can rectify it? Thanks.

I was replying to @titus7212 who commented about this SHIELD Face here Rob.

It seemed to work in tests up to 150F but I have increased the size even further to be sure.


The F-- is a NOP . Non operation. I cannot get a test to fail sorry

I’d suggest going up to 121F, as that is boiling in C, but I don’t think that Temp would be reached anywhere, at least, not on this planet :joy:

1 Like