FACER Community

Phone Battery on Watchfaces Not Operating

Update: The watch face I re-synced is still showing the battery level after breaking and reconnecting the Blutooth connection. I just swapped it for an old face already installed on my watch ( one that was not working ) and it is now showing the phone battery ok. Strange …

Hello all, wanted to share my 2 cents worth on my issue with phone battery indicator not updating. And how i seem to have fixed it for me.

My issue was my watch (Galaxy Watch Active) would not show correct phone battery level on any watchface that included phone battery monitor. If i sync’d watchface from facer (sometimes) it would sporadically update through out the day, but was consistently 30% or more off from what phone bettery level actually was.

My issue seems to have been related more phone side, than watch side.

I did the same Un-Install/Re-Install Facer, cleared cache and force stopped app, reboot phone and watch, etc…, but never fixed problem.

I then turned off Battery Optimization on phone (Galaxy Note 10+), never allowed phone to put Facer app to sleep, or disable. Rebooted phone and watch, re-synced Facer and watchface. I also enabled Phone Permission in Facer App, and now its RESOLVED.

It now consistantly shows Phone Battery level within 1% of what phone states. On another thread I read that Facer has this only update every 10 minutes for battery conservation on watch. Good enough for my purpose.

Hope this helps.

2 Likes

I have not noticed the problem recently but good to know there is a solution if it comes back. Thanks for sharing.

I have fixed the issue of Facer watch face not accurately displaying phone battery level:

Clearing cache, clearing data on Facer companion app, making sure to then re-allow all permissions on app, restarting phone and watch all work temporarily but HERE ARE THE BIGGEST 2 ITEMS. After you have done these things go to your phone settings–>battery settings–>battery optimization and pull up your list of apps/programs that are currently optimized (these are the apps or programs that your phone will allow to go to sleep or close completely when your phone decides it doesn’t need them). Make sure that your Facer app AND your Bluetooth are NOT optimized. In other words, turn them OFF of optimization. If you do these things then your phone and Facer watch face should ALWAYS stay completely synched. Worked for me right away.

2 Likes

I started having the same problem a few days ago; prior to that, the phone-battery indicator updated properly on my Facer Creator face. I tried the steps suggested above but they only fix the problem for a day or less before it resumes.

R820XXU1EUK2, S908U1UEU1AVA6
Wearable 2.2.47.21122061
Plugin 2.2.08.22012751
Facer 6.0.0_106333, 5.1.37

1 Like

This has been reported as a new issue for the new android update under Android companion app and time speed up

Please vote.

I just found another bug that was introduced on the last app update. The tags #WRmZ# and #WSmZ# which are sunrise and sunset minutes with leading zero have stopped displaying the leading zero on WearOS 2 watches. WearOS 3 and Tizen are working correctly. I’ve just finished sending @Facer_Official a bug report and included this screen shot showing them the issue.

1 Like

I’m seeing this leading zero on single-digit minutes of sunrise time on my Samsung Galaxy Watch 4 running WearOS 3.2, so I’m not sure WearOS 3 is immune to this problem. I couldn’t remember if this was a new issue or not, but it seems like it is.

Also, I’m seeing the phone battery level issues noted here where it’s updating slowly at best. Having synced a face earlier today to force it to update, it’s still showing 100% phone power about 3.5 hours later when it’s actually at 88% as I write this. I tried various things to fix this, but nothing seems to stick, unfortunately; it’s all temporary, as far as I can tell. The other thread mentioned here seems to suggest that this could be some kind of server issue, which I guess would make sense. I don’t know why information like battery power would have to go through a server instead of directly between phone and watch, but I’m new to smart watches.

1 Like

All I can say for sure is on my Fossil Carlyle sunrise & set times with leading zero minutes are broken, but my Galaxy Watch 4 and GW4 Classic the sunrise and set times are working properly along with my Galaxy Watch 1st gen running Tizen. There are several codes for the sunrise and sunset times so the issue may extend to WearOS 3 with the ones that I don’t use.

Good point. I’m looking at it from the user side, not the creator side, so I don’t know exactly what codes are being used on which faces. If only some sun rise/set codes have this issue with single-digit minutes though, that could explain the difference in behavior we see. Thanks for the info.

1 Like

I have always on enabled and it still does not work (WearOD 2 Fossil Gen 6)

Really strangely, it failed for a day, then worked for nearly a day and has not worked since. Synking a new face will statically update the current battery level but it does not update automatically after. I first reported this by email Saturday or Sunday.

Hi I have the inmotion watch face and my phone battery and watch battery puts in different numbers than what it should be is there anyway to fix this

A lot of differences in watch and phone battery levels can just be the refresh rate Facer is using in the app. I know phone battery levels will vary up to 5% at times depending on how fast the phone battery itself changes compared to the Facer update rate. The watch battery is normally a lot closer but can vary some also. Facer just came out with version 6.0.1 that may have fixed some of these issues. You might check and see if your app is the latest version.

1 Like

I have the 6.0.1 thanks this is an issue with the battery and phone battery on my watch it doesn’t sync the right numbers

6.0.1 has not fixed this issue for me, Fossil Gen 6, all up to date.
I did all the restarts after the update and also synced different faces and deleted all the ones I had had before, just in case.
I thought I’d wait a few days to observe.
It does seem to change occassionally but if so at a minimum interval of 15 hours.

hello I encountered the same problem with my galaxy watch 4 and my samsung s21 the battery charge level is not up to date and yet I have updated everything.

yet everything was working fine before the update of the watch

Hello, I come to bring a temporary solution to troubleshoot the time that facer solves the problem.
After several tests I reached a result the problem will come from the phone application and not from the watch because on the watch I am still in version 6.0.1_106392 on my watch (galaxy watch 4) but I downgraded the phone version I upgraded to version 5.1.72_106101 for the phone (galaxy S21) it is still available on galaxy store
And the my watch And my phone synchronizes the phone battery again everything works perfectly as long as facer does not update the version of the galaxy store this temporary and valid solution.

1 Like

Thabnks. It is good to have a second confirmation that it is possible to downgrade the phgone app to the last version this feature was known to work in but I got Facer from the Google, Play store and there is no going back there other than uninstalling and then hunting the Galaxy store for a previous verssion.

I also would like to monitor the newest verstions so as to be able to provide feedback on the success of the fixes going forwards.

Bump. Battery not updating on watch. If i add a new face to the watch, the battery updates. but only one time.

Manually doing this every time is pointless as i have to pick up the phone to do so. When i do so i already know the battery status on the darn thing by looking at it…

both facer and wearable set to neversleep. permission in order too.

running watch 5.1.37.3 / phone 6.0.1_106395.phone
SM-R770 / SM-N975U

3 Likes

Yeah. The 6.01 update did not fix it. Waiting on 6.02.

If you are not a creator and just want your faces fixed, and have a Samsung phone, you can uninstall and install the latest 5.x version from the Galaxy Store (Play store does not offer earlier versions but apparently Gallaxy sotore does). It was 8,06.0 that broke stuff. Then just read here for updates on whether 6.0.2 will fix it.

As a creator I will stick to latest version to keep testing the updates.

2 Likes