Phone Battery on Watchfaces Not Operating

Keen to know of any updates on this issue. Having the same problem (Galaxy S8 and Gear S2). Have tried the permissions and force stop but that only worked for a short time after that the stopped syncing the phone battery percentage again.

Are you using a free face or a premium face? This isn’t a perfect fix but if you are using a premium “themeable” face you can force a connection between the app and your face by changing the themed color within the app. This isn’t ideal but it’s a quick fix for the time being.

It’s a premium face. But one of the things I do to try to get phone percentage back is change the watchface, usually to one that has battery percentage and does work. Then change it back to facer later. Sometimes it works but most of the time not.

I had the same problem, I deleted the watchface from my watch, looked it up in the Facer program on Internet and reloaded it. After that everything was oké again.
The problem occurred when I was charching phone and watch at the same time, could that be the issue??

Hello I have the same problem,
I deleted the frame from my watch but nothing change.

I’ve not heard of this being a problem, charging at the same time. I can’t say yes or no but most of the time when facer issues happen on a Tizen device it’s because the facer companion was not updated after Facer releases a patch. Facer is constantly working on improving this platform so a lot of patches are released. I’d say anytime something stops working go check the Samsung store to make sure that your facer companion app is updated to the moat current version. That so far has always fixed my problems because for some reason the Samsung store won’t auto update apps for me. @mickael.payton @wyb1

Hello
My facer companion version is 5.1.0
How can i find the last for tizen ?

That is the current version.

I have noticed that Facer watch faces and even one through Galaxy Apps (called All-In-One which uses a companion app called GDP) BOTH quit updating phone battery anytime there is a break in BT connection. When the watch re-establishes connection, the phone battery complication stops working.

Since this issue is consistent with Facer and non-Facer apps, either both have the same method of communication to Tizen devices and/or the glitch is in Tizen.

I have tried this on my galaxy watch but it didn’t work it will update but its random not right away and i have a galaxy 10 plus with a galaxy watch

@Facer_Official, @Facer-Staff

All of my watchfaces have stopped showing the phone battery level.

Watch: Samsung Galaxy Watch

Galaxy Wearable: 2.2.24.19031361
Galaxy Watch PlugIn: 2.2.05.19050851

Watch Software: R800XXU1CSD6/R800OXA1CSD6/

Facer ( phone app ): 5.1.14_101131-(101131) ( problem noticed on previous version, this update had no impact )

Facer Companion ( watch ): 5.1.5

edit:

  1. I don’t know if it is related or not but I am also having trouble syncing faces… I have to restart my watch before I can sync any faces. Some time after this it again loses the ablity to sync and I have to restart my watch again.

  2. I just restarted my phone and watch again and re-synced one of my old faces. The phone battery is now showing. I will check to see if this continues.

Update: The watch face I re-synced is still showing the battery level after breaking and reconnecting the Blutooth connection. I just swapped it for an old face already installed on my watch ( one that was not working ) and it is now showing the phone battery ok. Strange …

Hello all, wanted to share my 2 cents worth on my issue with phone battery indicator not updating. And how i seem to have fixed it for me.

My issue was my watch (Galaxy Watch Active) would not show correct phone battery level on any watchface that included phone battery monitor. If i sync’d watchface from facer (sometimes) it would sporadically update through out the day, but was consistently 30% or more off from what phone bettery level actually was.

My issue seems to have been related more phone side, than watch side.

I did the same Un-Install/Re-Install Facer, cleared cache and force stopped app, reboot phone and watch, etc…, but never fixed problem.

I then turned off Battery Optimization on phone (Galaxy Note 10+), never allowed phone to put Facer app to sleep, or disable. Rebooted phone and watch, re-synced Facer and watchface. I also enabled Phone Permission in Facer App, and now its RESOLVED.

It now consistantly shows Phone Battery level within 1% of what phone states. On another thread I read that Facer has this only update every 10 minutes for battery conservation on watch. Good enough for my purpose.

Hope this helps.

2 Likes

I have not noticed the problem recently but good to know there is a solution if it comes back. Thanks for sharing.

I have fixed the issue of Facer watch face not accurately displaying phone battery level:

Clearing cache, clearing data on Facer companion app, making sure to then re-allow all permissions on app, restarting phone and watch all work temporarily but HERE ARE THE BIGGEST 2 ITEMS. After you have done these things go to your phone settings–>battery settings–>battery optimization and pull up your list of apps/programs that are currently optimized (these are the apps or programs that your phone will allow to go to sleep or close completely when your phone decides it doesn’t need them). Make sure that your Facer app AND your Bluetooth are NOT optimized. In other words, turn them OFF of optimization. If you do these things then your phone and Facer watch face should ALWAYS stay completely synched. Worked for me right away.

2 Likes

I started having the same problem a few days ago; prior to that, the phone-battery indicator updated properly on my Facer Creator face. I tried the steps suggested above but they only fix the problem for a day or less before it resumes.

R820XXU1EUK2, S908U1UEU1AVA6
Wearable 2.2.47.21122061
Plugin 2.2.08.22012751
Facer 6.0.0_106333, 5.1.37

1 Like

This has been reported as a new issue for the new android update under Android companion app and time speed up

Please vote.

I just found another bug that was introduced on the last app update. The tags #WRmZ# and #WSmZ# which are sunrise and sunset minutes with leading zero have stopped displaying the leading zero on WearOS 2 watches. WearOS 3 and Tizen are working correctly. I’ve just finished sending @Facer_Official a bug report and included this screen shot showing them the issue.

1 Like

I’m seeing this leading zero on single-digit minutes of sunrise time on my Samsung Galaxy Watch 4 running WearOS 3.2, so I’m not sure WearOS 3 is immune to this problem. I couldn’t remember if this was a new issue or not, but it seems like it is.

Also, I’m seeing the phone battery level issues noted here where it’s updating slowly at best. Having synced a face earlier today to force it to update, it’s still showing 100% phone power about 3.5 hours later when it’s actually at 88% as I write this. I tried various things to fix this, but nothing seems to stick, unfortunately; it’s all temporary, as far as I can tell. The other thread mentioned here seems to suggest that this could be some kind of server issue, which I guess would make sense. I don’t know why information like battery power would have to go through a server instead of directly between phone and watch, but I’m new to smart watches.

1 Like

All I can say for sure is on my Fossil Carlyle sunrise & set times with leading zero minutes are broken, but my Galaxy Watch 4 and GW4 Classic the sunrise and set times are working properly along with my Galaxy Watch 1st gen running Tizen. There are several codes for the sunrise and sunset times so the issue may extend to WearOS 3 with the ones that I don’t use.