Steps not working Ticwatch Pro

Step count suddenly stopped working on my Ticwatch Pro. I’ve reset the watch and re installed the Facer app and still can’t get it working. Any ideas? Wear OS 2.3, Android 8.0.0

1 Like

Could it be related to this?

Yep. That’s exactly when it started.

Same here. I have a Fossil watch. This is not fun for people who use their activity stats daily.

1 Like

Same with my Huawei sport…understand it is related to the WearOS update.
I hope this will be fixed ASAP

I have a Ticwatch Pro and step counter isn’t working for me either.

I have the same problem. Non-functioning step counter. I’ve done a complete reinstall of everything, watch and phone, but the problem persists. What is it caused? In MR.Time, the step counter works, but it’s not as good as Facer, I do not want to use another application, but the step counter is important to me. Thank you for answer.

It is a known issue with Wear OS. Face says that they are working on it. It has been happening since late January.

Does anyone know why and when it will be that this problem fixed?

Hi @roman.w.hardy! This is fixed in Facer 5.1.5 - you can see the latest info on this issue here: [FIXED] Step counter not working on WearOS watches

If you are still having issues, please contact us at and we’ll work with you to get it fixed. Cheers!

I have a TicWatch Pro and it’s not working for me either. I only purchased the watch about a week ago, Facer was working okay for the first few days but it has stopped working the last couple of days. I’m using Facer version: 5.1.12_101073

I sent an email to giving more details but posting here as well.

Hi all! We are investigating this issue with Google, but we’ve heard from multiple users that uninstalling and re-installing Google Fit on your phone may fix the issue. If you’re having step counter issues, could you try that and let us know if it fixes the issue for you too?

1 Like

Uninstall and reinstall of Google Fit and Facer only fixed it for a couple days. Kinda mind boggling why it worked for those couple of days and then suddenly didn’t…I have no idea as I don’t really touch my watch, having all complications right there in front of me

I am having trouble with my TicWatch Pro as well. the step counter does not work and the weather data does not show up now. Everything worked fine about a week ago. Then all of a sudden it went blank. I have restarted both my phone and watch but no change. Any advice?