Weather temperature not updating

For the past couple of weeks the weather temperature has stopped updating on my Gear 3 and nothing on my end changed. Does anyone know why?

I’m not sure, but has been having issues with Facer Creator and the rest of the website going offline. I’ve noticed it also with the phone app not being able to update. I’ve even had it sign me out of both at times when it’s gone down. I’m not sure what is going on, but I hope that @Facer_Official is aware of the issue and working on getting it fixed. Oddly though, the Facer Community and Facer Help Pages have been fine.

The #ALT# and #ATM# have stopped functioning on ALL
the watchfaces I have created. They both return “0” for current
value. Samsung Galaxy Watch 46mm. iPhone XR.
This started last weekend. I updated a bunch of apps on my phone
last weekend also. Not sure if Facer was one of them.
I know it’s not the watch because the Samsung Altitude/Barometer app
that comes on the watch are showing values as Normal. Same with
a downloaded app Alt Barometer that I use on the watch, fine.

Deleted the Facer companion app from my Samsumg Galaxy watch 46mm and
then reinstalled(the download link is in your app list on the Galaxy watch app) via the Galaxy watch app on iPhone and they both(#ALT#,#ATM#) work again. I did NOT delete the Facer app on the Iphone though. Figured I could go nuclear if this didn’t work. It did.
Followed up to help someone who searches for the same problem.


I see this post is one year old but I’m facing this issue.
I assuming Facer did not fix this bug?

Not sure, but it’s happened to me a few times in the last year.
The solution I posted still works for me though when needed.
To be a bit more specific on where the reinstall link is:
After deleting the Facer app from the watch,
Go to your Galaxy app on your phone,
Click Apps
Click Manage Apps
Click the 3 dots, upper right
Click Download History
(Might ask you to sign into your Samsung account
if you got logged out)
Then click the Facer app and reinstall
Facer will be back on you watch and
Weather now working

Reinstalling the app on my watch worked, thanks!
But if the issue comes back every time I switch off my watch, that’s gonna be a big turn off for me to keep using @Facer_Official

Just turning watch off does not trigger the temperature etc failure
for me. Like I said, only happens a few times a year.
Probably a watch memory allocation issue.
Glad the fix worked out for you

What I’ve discovered is all you need to do is set your watch to a non-Facer watch face. Next turn off both the watch and the phone, then turn both on. When fully on and stabilized open the Facer app on the phone then switch to a Facer face on the watch and it should work just fine. At least that’s how I get it to work on my Samsung watches. Oddly enough I’ve never had that issue with my Fossil watch.


I have tried the latest post steps, but it’s not working for me.
I’m using Galaxy Watch 4 with latest firmware update and S22 Ultra with latest firm too.
Weather is not updating at all

Have you restarted your watch and checked to make sure location permission is turned on PLUS location in the watch and phone both have to be turned on for weather to work. If you have location turned on in just the watch but not the phone it won’t work at all.

1 Like

Location is on for Facer phone app and Watch companion, plus Facer phone app. is set to unrestricted for power use.
Also app. as well as companion was reinstalled just in case… do I need to have any weather app installed on the phone?

Was it working recently, then stopped?
Did you follow steps I posted above?

No need for an app because Facer uses OpenWeather. I have read some here in the community say that having the OpenWeather app installed on your phone helps. I’ve had it both ways and didn’t really see a difference. Just make sure you restart your watch. A LOT of people have been having issues with weather and steps and after they restart the watch it is magically fixed. I make it a practice to turn my watch off every time I charge it. That way it automatically gets restarted every two to three days.

-Yes it was working and then stopped at all (complication was completely blank)
-I did full steps above

My bad! I’ve found what was going on… probably when reinstalling I missed giving companion location access… after giving it back now it’s showing weather. We’ll see if it keeps updating it periodically (Because originally was providing weather temp, but not updating it).
Do you know how often or is it configurable temp is updated?

It doesn’t update very often. I don’t know an actual time frame for it’s updating. I have found personally if you open the Facer app on your phone 3 or 4 times a day just for 15 seconds or so it will force the watch to update the weather. I’ve looked at my watch several times and thought that the temperature can’t be right. I’ll open the Facer app on the phone, close it and check my watch and the temperature has updated to something more realistic. I’ve been on Facer since 2019 and people were complaining about the weather updating way before I ever came. It’s just one of those issues that just ‘is’.

1 Like

Glad you got it working.
Here’s another hack for the Galaxy that may blow your mind,
but it works for me, YMMV.
Have Galaxy app open on phone(I have iPhone so this may not work for Android)
Connect your watch to WiFi at home, work wherever you use Wifi
by putting in Wifi and network password. Turn Wifi ON in watch.
You can now close Galaxy app on phone.(Bluetooth connects still stay active.)
I don NOT run the Facer app open on my phone either.
For me-
-weather updates immediately constantly(not every 3 hours)

  • syncs happen lightning fast.
    -watch reconnects with phone after separation easily and quick.
    If watch ever gets disconnected just restart Galaxy app then close again.
    If you use sleep tracking this won’t update without Galaxy app open.
    But for everyday use, this works great and makes the watch much more
    pleasurable to use.
1 Like