Steps not showing on Facer watch faces

On my facer watch faces, the steps are always 0, but when I got into the google fit app, it says the real count. How can i get the real count on the watch face?


Did you ever get an answer to this?

I am having this problem on every face I select…steps are always 0 but are correct in Google Fit?? Tried turning off/on Bluetooth and restarting watch. All faces are doing the same :pensive::thinking:

I am using Huawei watch 2 2018, and on my watch facer faces it always shows 0 steps counts, while on stock faces it always shows correct steps count. I don’t know how to sync watch facer, so it shows the step count then. Please help


Don’t worry…It’s not anything you are doing wrong. It seems the step count is not working on most Facer faces with watches using Google Fit/Wear OS. Keep checking the main page of the forum for updates! Hopefully they will get it fixed soon! :blush::+1:

1 Like

Same problem

Hi all! This is now fixed in Facer 5.1.5. More info here: [FIXED] Step counter not working on WearOS watches

I’m still having this issue with all Facer displays on my Samsung Watch 4 classic, as well as calories burned and active time also showing zero on all displays. Any help?

1 Like

I have upgraded to 5.1.8, but it still doesn’t work.i am using samsung watch4.

i have the same issue. I even allowed everything in permissions, restarted, updated, deleted. Everything else works, but not steps.

I am on a Samsung Classic 4 and mine were working 2 days ago but now it’s not even working on other watch face apps. The system “Samsung Health” still shows my steps. Could It be a Samsung issue?