[FIXED] Step counter not working on WearOS watches

Hi all,

We’ve received a number of reports that the step counter is showing 0 for a some WearOS users. The issue seems to have started happening around January 28th and appears related to a WearOS or Google Fit update.

We have confirmed the issue and are currently working with Google to fix it ASAP. We’ll keep you posted on this thread as soon as we have more information we can share.

Thanks for your patience!

Update February 15th: we are still working on the issue, which has now been confirmed by Google. For more details, and possible temporary workaround, please see our comment here: [FIXED] Step counter not working on WearOS watches

Update February 21st: this issue was escalated within Google and we are continuing to work with them on that. While this is being fixed, we are putting together a collection of free watch faces with WearOS complications that will show you your Google Fit step count: Fun with WearOS complications - watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more - Facer. To show your steps, just long press on the face to update one of the complications and select the “Step Count” option from Google Fit. We will be adding a lot more free faces in that collection in the next few days.

Update February 27th: Thanks SO MUCH for your patience. I’m happy to report that our engineering team found a workaround which should make the step counter work for every face. The fix is being tested as we speak and should be available to to beta users and then worldwide in a matter of days. Stay tuned!

Update February 28th: Facer 5.1.5 is available in BETA and includes a fix for the step count issue. If you would like to join the beta, please follow the steps here. We’re hoping to make 5.1.5 available to all users before the end of the week. Thanks for your patience!

Update March 1st: FIXED: Facer 5.1.5 is now available worldwide! To fix the step count issue, please make sure you upgrade to that version in Google Play. You may be asked to login to Google Fit the first time you load a watch face with step counts, but it should work after that. We heard from some users that uninstalling and re-installing Google Fit may also be necessary. THANKS SO MUCH FOR YOUR PATIENCE!

43 Likes

I miss the step counter, I hope it gets fixed soon! Huawei watch.

4 Likes

Thank you and hope it gets resolved soon!! I am having same issue in my Kate Spade Scallop, while using Facer watch faces, and shows steps as 0. I’ve updated the Google Fit app today hoping it would fix but still shows 0. Keep us posted please!

1 Like

Step counter not working for Tag Heuer Connected

Any updates?

2 Likes

Thank you for the update!!Will you guys plz let us all know when/if the issue is resolved?

2 Likes

Yes please fix! It’s been stuck at zero on my ticwatch e for a couple week now :persevere:

2 Likes

Any news?

1 Like

Any news on if or when we will get the steps function working again?

The last update from Facer was 8 days ago, surely there is some news, even if the news is they are still working on it. My issues is worse that the date no longer updates either and the weather is not representative of where I am. If things worked it would be worth going premium but how can they currently justify it?

Any word yet as to the ongoing issue with the step counter not working?Getting pretty frustrating

1 Like

Thank you for letting us know. I have the fossil Gen 4 and it’s not working either.

Hi all,

Apologies for the lack of updates - we are trying to make sure we inform you only when there is progress.

The issue was confirmed by Google and we are working with the WearOS team to solve it. For those interested in the technical details, the crux of it is that direct access to Google Fit data from watch faces isn’t functional anymore since a recent update of WearOS. This was not intentional and is being corrected on the Google side.

Unfortunately as of today, the issue is still present. While we wait for the fix, we are looking into ways to bypass Google Fit altogether to reactivate steps data, but these ways are typically not very accurate.

In the meantime, one workaround if you would like your Google Fit steps visible on a watch face is to use faces that use WearOS complications, like the ones listed here: Facer - Thousands of FREE watch faces for Apple Watch, Samsung Gear S3, Huawei Watch, and more
On any of these faces, you can update the data shown in the complication (just long press on the face, then tap edit, and tap the complication you’d like to change). If you select Google Fit and steps data, it should work that way.

Thanks for your patience while we solve this with Google for all Facer faces!

2 Likes

This is a serious issue to go on this long. Coming up on 3 weeks is not ok

3 Likes

I have hade Facer since dec 28/18 most of time have been waiting because og Update problems :frowning: not a wery stable app…

2 Likes

You are absolutely correct!And given the magnatude of what kind of company Google is,to say that this issue is very frustrating doesn’t even begin to cover it.

So,plz correct me if I am wrong here but using the Facer faces in this link provided will allow the step counter to work/be seen until Google can get this issue resolved?Are there any additional steps/apps needed to make this work?Thanks😊

Anyone know how to get Facer to respond to an issue that you are experiencing with a watch face? (The temp is showing a ? instead of a minus symbol.) The watch designer (G7 - Digital Infos Series 5.5) told me that I needed to contact Facer. I have tried posting in the community forum. I have tried submitting a request. I have tried email. It has been about 3 weeks and I’ve heard absolutely nothing. I’d like to purchase a couple more watch faces but refuse to spend any more $ if the customer service is this poor.

1 Like

Hi @muddywaters - can you share the ticket # you received when you emailed? We’ll look into it. Thanks!